this post was submitted on 16 Jan 2024
546 points (98.8% liked)

Programmer Humor

19564 readers
860 users here now

Welcome to Programmer Humor!

This is a place where you can post jokes, memes, humor, etc. related to programming!

For sharing awful code theres also Programming Horror.

Rules

founded 1 year ago
MODERATORS
 
you are viewing a single comment's thread
view the rest of the comments
[–] [email protected] 98 points 10 months ago (22 children)

Put it in an if-else and it executes both blocks.

[–] [email protected] 0 points 10 months ago* (last edited 10 months ago) (9 children)

Screw else statements, people who use if-return have 180% more readable code.

[–] [email protected] 3 points 10 months ago

It's much more readable when you use else depending on the checks. You can still use return in an else block.

def Allowed()

  if name == "Octopus1348": return True

  elif name == "Bobert": return True

  else:
        return "You are not allowed to use this script."

print(Allowed())

`

load more comments (8 replies)
load more comments (20 replies)